CLICK & Online EFTPOS - Transaction visibility

Incident Report for Cuscal Paymark

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 19:58 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 15:56 NZST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 09, 2026 - 15:54 NZST

Investigating

We’re currently aware of an issue where some Online EFTPOS transactions processed via a CLICK integration are not appearing in the CLICK Portal. This may result in transactions being charged but the associated orders not completing.
 
This issue does not impact Online EFTPOS transactions that are not integrated with CLICK.
Posted Sep 09, 2026 - 15:31 NZST
This incident affected: Service Status (CLICK, Online EFTPOS).