Ruralco Declining Transactions

Incident Report for Cuscal Paymark

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 15:04 NZST

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 14:34 NZST

Investigating

Paymark is aware of an issue causing Ruralco transactions to decline.

Our team are investigating and an update will be provided soon.

Thank you for your patience.
Posted Jul 08, 2026 - 14:30 NZST
This incident affected: Service Status (Payment Switch / EFTPOS).